phpenvのビルドが毎回コケてる気がするのでそろそろいい加減にメモしておこうっていう温度感のメモ

環境

Macでコケてる記事が多いけど、こちらの記事はDebianとなっております

1
2
$ cat /etc/debian_version
9.5

急いでいる人用

この記事に出てくるパッケージを全部まとめたものがこちらです

1
2
3
4
5
6
7
8
9
10
sudo apt-get install -y libxml2 libxml2-dev \
libssl-dev pkg-config \
zlib1g-dev \
libbz2-dev \
libjpeg-dev \
libpng-dev \
libreadline-dev \
libtidy-dev \
libcurl4-openssl-dev \
libxslt1.1 libxslt-dev

configure: error: libxml2 not found. Please check your libxml2 installation.

1
2
3
4
$ sudo apt-get install -y libxml2
libxml2 はすでに最新バージョン (2.9.4+dfsg1-2.2+deb9u2) です。

$ sudo apt-get install -y libxml2-dev

configure: error: Cannot find OpenSSL’s libraries

1
2
3
4
$ sudo apt-get install -y libssl-dev
libssl-dev はすでに最新バージョン (1.1.0f-3+deb9u2) です。

$ sudo apt-get install -y pkg-config

configure: error: cannot find libz

1
$ sudo apt-get install -y zlib1g-dev

configure: error: Please reinstall the BZip2 distribution

1
$ sudo apt-get install -y libbz2-dev

configure: error: jpeglib.h not found.

1
$ sudo apt-get install -y libjpeg-dev

configure: error: png.h not found.

1
$ sudo apt-get install -y libpng-dev

configure: error: Please reinstall readline - I cannot find readline.h

1
$ sudo apt-get install -y libreadline-dev

configure: error: Cannot find libtidy

1
$ sudo apt-get install -y libtidy-dev

configure: error: xslt-config not found. Please reinstall the libxslt >= 1.1.0 distribution

1
2
3
4
$ sudo apt-get install -y libxslt1.1
libxslt1.1 はすでに最新バージョン (1.1.29-2.1) です。

$ sudo apt-get install -y libxslt-dev

configure: error: cURL version 7.10.5 or later is required to compile php with cURL support

1
$ sudo apt-get install -y libcurl4-openssl-dev